Професионална програма
Loading...
n1p3ha avatar n1p3ha 20 Точки

Проблем с Spring

От известно време не мога да пусна Spring. Тръгва но не прави нищо. Стартира само трите реда и това е.

Starting MainApplication on ivanof-Aspire-E1-772G with PID 27375

No active profile set, falling back to default profiles: default

Started MainApplication in 0.368 seconds (JVM running for 0.687)

 

От начало вървеше, но не мога да намеря проблема! Ето и какво се опитвам да направя, само тествам и не става:


@Entity
@Table(name = "employee")
public class Employee {

    @Id
    @GeneratedValue(strategy = GenerationType.IDENTITY)
    @Column(name = "id")
    private Long id;
    
    @Column(name = "name")
    private String name;

    public Employee() {
        super();
    }

    public Long getId() {
        return id;
    }

    public void setId(Long id) {
        this.id = id;
    }

    public String getName() {
        return name;
    }

    public void setName(String name) {
        this.name = name;
    }
}

Това са dependences и build

<dependencies>
    <!-- https://mvnrepository.com/artifact/mysql/mysql-connector-java -->
    <dependency>
        <groupId>mysql</groupId>
        <artifactId>mysql-connector-java</artifactId>
        <version>5.1.40</version>
    </dependency>

    <dependency>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-data-jpa</artifactId>
        <version>1.4.1.RELEASE</version>
    </dependency>

</dependencies>

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.5.1</version>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

Това ми е application.properties:

#Data Source Properties
spring.datasource.driverClassName = com.mysql.jdbc.Driver
spring.datasource.url = jdbc:mysql://localhost:3306/test_spring?useSSL=false&createDatabaseIfNotExist=true
spring.datasource.username = root
spring.datasource.password = 123456

#JPA Properties
spring.jpa.properties.hibernate.dialect = org.hibernate.dialect.MySQL5InnoDBDialect
spring.jpa.properties.hibernate.format_sql = TRUE
spring.jpa.hibernate.ddl-auto = create

###Logging Levels
# Disable the default loggers
logging.level.org = WARN
logging.level.blog = WARN

#Show SQL executed with parameter bindings
logging.level.org.hibernate.SQL = DEBUG
logging.level.org.hibernate.type.descriptor = TRACE
Тагове:
0
Ivanov.Ivan avatar Ivanov.Ivan Trainer 558 Точки
Best Answer

Пробвай да подмениш build - а с този

 

<build>
        <plugins>
            <plugin>
                <groupId>org.springframework.boot</groupId>
                <artifactId>spring-boot-maven-plugin</artifactId>
            </plugin>
        </plugins>
</build>

 

0
RoYaL avatar RoYaL Trainer 6846 Точки

Дали не трябва и parent?

0
Ivanov.Ivan avatar Ivanov.Ivan Trainer 558 Точки

Показал е само депенданситата и билда .. предпоалгам парента присъства ... 

0
n1p3ha avatar n1p3ha 20 Точки

колеги не се смейте, гадно е ама:

Имам си и parent!

Всичко си е наред с конфигурацията - забравил съм @SpringBootApplication анотацията на мейна.

Все пак Ви благодаря много.

0
13/11/2016 20:03:34