Проблем PHP -Symfony-Installer-"cURL error 77"

Проблем PHP -Symfony-Installer-"cURL error 77"

Bojidar_At avatar Bojidar_At 6 Точки

Проблем PHP -Symfony-Installer-"cURL error 77"

Здравейте,

Тъй като нямах време и пропуснах лекциите за PHP, а сега го имам и се опитвам да наваксам, моля за малко помощ. Получавах cURL error 60, като съгалсно инструкциите напарвих корекции в php.ini и добавих cacert.pem файла. Спрях да получавам cURL error 60, но тогава получих следната грешка:

Symfony-Installer
                cURL error 77: error setting certificate verify locations:  
                CAfile: C:\xampp\php\extras\ssl\cacert.pem                
                CApath: none                                              
                [GuzzleHttp\Ring\Exception\RingException]                   
                cURL error 77: error setting certificate verify locations:  
                CAfile: C:\xampp\php\extras\ssl\cacert.pem                
                CApath: none                                              
                new <directory> [<version>]
                PHP Warning:  Module 'openssl' already loaded in Unknown on line 0

 

Пробвал съм всякакви комбинации с cURL файла и директорията в която да го сложа, но продължава да ми дава тази грешка. 

Тагове:
worminer avatar worminer 104 Точки

Значи до колкото прочитам в нета е много важно файла да е "cacert.pem.txt" като незнам дали ти е нагласено да виждаш файловите разширения на познатите типове файлове..
и другото което е важно пътя който ползват е "curl.cainfo = C:\xampp\php\cacert.pem.txt".. хората казват че като го сложат в друга папка и не работи..
като при тебе най вероятно пътя трябва да е същия понеже папката на xampp ти е в C:\

!!! Като при всяка промяна трябва да рестартираш apache сървара за да влязат новите промени в сила !!!

И също така може да пробваш с curl.cainfo = "C:\xampp\php\cacert.pem.txt" като кавичките са задължителни ако в пътя има интервал.. като при теб това не би трябвало да е задължително ама ..

0
22/11/2016 14:41:31
Bojidar_At avatar Bojidar_At 6 Точки

Пробвам всякакви варианти с разширението на файла и папката в която да го сложа, но продължава да излиза тази грешка.

Symfony-Installer
                cURL error 77: error setting certificate verify locations:  
                CAfile: C:\xampp\php\cacert.pem.txt                       
                CApath: none                                              
                [GuzzleHttp\Ring\Exception\RingException]                   
                cURL error 77: error setting certificate verify locations:  
                CAfile: C:\xampp\php\cacert.pem.txt                       
                CApath: none                                              
                demo [<directory>]
                PHP Warning:  Module 'openssl' already loaded in Unknown on line 0

 

Предполагам, че проблема трябва да е някъде другаде... но къде ?

0
worminer avatar worminer 104 Точки

когато отвориш някоя папка/my computer и горе в лентата напишеш C:\xampp\php\cacert.pem.txt и натиснеш enter отваря ли ти се файла в текстовия редактор.. защото тази грешка означава че не си направил правилно пътя..

другото за което се сещам е дали едитваш правилното php.ini .. правилното е "C:\xampp\php\php.ini" (това го казвам понеже в някой версии на xampp съм срещал повече от 1.. които просто си стоят там и не се ползват)
също така може да пробваш да дадеш права на всички потребители (което няма логика да е проблема ама що пък не) като отвориш конзолата и напишеш тази команда

icacls "C:/xampp/php" /grant Everyone:(OI)(CI)F /T

Edit: напрактика като гледам всичко си направил правилно защото в този туториал пише точно това което си напрпавил..
https://docs.bolt.cm/3.0/howto/curl-ca-certificates

0
22/11/2016 15:52:56