[Homework][Technical Issue] Грешка при зареждането на сървъра на Battleships - Софтуерен университет

[Homework][Technical Issue] Грешка при зареждането на сървъра на Battleships - Софтуерен университет

+ Нов въпрос
Hristo_Penchev avatar Hristo_Penchev 388 Точки

[Homework][Technical Issue] Грешка при зареждането на сървъра на Battleships

Здравейте, 

Тръгнах да правя домашното Battleships. Изтеглих проекта и като го стартирам ми отваря началната страница. След това обаче като дам на API, да видя заявките, Хром ми дава следната грешка:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

<Error>

<Message>

No HTTP resource was found that matches the request URI 'http://localhost:62858/Help'.

</Message>

<MessageDetail>

No type was found that matches the controller named 'Help'.

</MessageDetail>

</Error>

 

Опитах през Интернет експлорър и пак ми дава грешка. Разрових в Гугъл, има го този проблем, но не намерих обяснение. Опитах да ребилдна проекта, но това не помогна. Моля ако някой се е сблъсквал, да сподели.

0
C# Web Services & Cloud 23/08/2015 00:12:05
a_rusenov avatar a_rusenov 1103 Точки
Best Answer

Оправено е, вече не би трябвало да има проблем с help страниците. Впрочем имате качен и postman-queries.json, който можете да си импортирате в postman и автоматично ще генерира заявки.

0
a.angelov avatar a.angelov 1332 Точки

А какъв беше проблема с help страницата? Да знаем все пак smiley

ЕДИТ. Видях къмита, няма нужда от отговор :)

0
23/08/2015 09:36:20
a.angelov avatar a.angelov 1332 Точки

Погледни къмита в гитхъба.

0
a.angelov avatar a.angelov 1332 Точки

При мен е същото положението, явно по някаква причина не може да мапне route-а към help контролера. Не видях някакви разлики в проекта с тези от домашните досега /с изключение на ninject-а/.

Предполагам някой от екипа ще се включи с обяснение и решение на проблема.

/OFF: Може да смениш категорията на въпроса на - Уеб услуги и Cloud, за да излиза в конкретния курс, че така е за цялото ниво.

0
23/08/2015 00:02:53
Dominik avatar Dominik 82 Точки

Здравейте и от мен,

Ще ползвам твоята тема за да споделя и на мен каква грешка ми хвърля (получава се при опит да стартирам проекта)

 

Целият следобед си изгубих в опити да я оправя, намерих доста теми в нета с подобна грешка опитах предложените решения, но не помогнаха.. Ако някой се е сблъсквал вече и е намерил решение бих се радвал да го сподели.

 

0
a_rusenov avatar a_rusenov 1103 Точки

Изглежда сякаш някой друг процес ползва този порт. Пробвай да смениш порта на проекта от Properties > Web > Project URL на друг.

1
23/08/2015 04:46:26
Dominik avatar Dominik 82 Точки

Странно никъде не го показваше като зает, но след като го промених на друг свободен порт взе та запали :). 

Благодаря

0