Софтуерно Инженерство
Loading...
and1teachera avatar and1teachera 19 Точки

JSP no response

Здравейте,
имам следния проблем, когато се опитам да заредя jsp страница, сървъра не ми връща никакъв response и в следствие от това получавам празна страница! Това се случва и на tomcat7 и на tomcat8. В конзолата не изкача никакъв проблем. Кода на jsp-то е верен, сървъра работи, url-а е проверен, но response няма! Някакви идеи?
 

Headers от браузъра :

    1. Request URL: http://localhost:8088/EJB/pages/Login.jsp Request Method: GET Status Code: 200 OK Remote Address: [::1]:8088

  1. Response Headersview source
    1. Content-Length: 0 Date: Sat, 13 Feb 2016 11:22:46 GMT Server: Apache-Coyote/1.1

  2. Request Headersview source
    1. Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8 Accept-Encoding: gzip, deflate, sdch Accept-Language: bg-BG,bg;q=0.8,en;q=0.6 Connection: keep-alive Cookie: JSESSIONID=7988165BC543FF894C8C1AC6C7428DA3

    2. Host: localhost:8088 Upgrade-Insecure-Requests: 1

    3. User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36

Тагове:
0
Java Web Development 13/02/2016 13:40:19
and1teachera avatar and1teachera 19 Точки

прави впечатление, че response-a e със код HTTP/1.1 200 OK
освен това на сървъра съм качил проектите от старите домашни и при тях този проблем го няма. излишно е да казвам, че рестартирах сървъра и eclipse поне 10 пъти.
Отделно като реша да направя нов проект (Dynamic Web Project) и вътре да копна по папките файловете от стария, проблема се повтаря. Явно има нещо по конфигурацията на проекта което ми бяга, но какво... 

0
13/02/2016 14:31:01
deyan.zhekov avatar deyan.zhekov 159 Точки

Здравей,

какво се случва ако в нов проект добавиш само Login.jsp файла и се опиташ да го достъпиш?

0
and1teachera avatar and1teachera 19 Точки

Направих нов проект и сложих само Login.jsp в tomcatEE и нямаше никакъв проблем. До момента след като правех нов проект добавях всички файлове наведнъж и не се получаваше. Сега добавих и package-a със servlet-ите и проблема отново го има. Написах отново анутациите, но и това не помогна

0
13/02/2016 16:05:50
deyan.zhekov avatar deyan.zhekov 159 Точки

Здравей, 

трудно ми е да преценя къде точно е проблемът без да виждам целия проект, но погледни за следните неща:

1. Имаш ли друг servlet, който да има същия mapping?

2. Имаш ли филтър, който да redirec-ва към нещо друго, което е празно?

3. Има ли нещо, което да изчиства самия response?

Алтернативно добавяй останалите файлове един по един докато откриеш в кой точно е проблема.

0
and1teachera avatar and1teachera 19 Точки

проблема идваше от един от servlet-ите. Написах го отначало дефинирах го в дескриптора и сега всичко е наред. Благодаря много за помощта!

0