Професионална програма
Loading...
chrisBG69 avatar chrisBG69 29 Точки

Проблем с датата в динамичния блог

В блога датата ми излиза така: Sat Jul 14 2018 13:10:04 GMT+0300 (FLE Daylight Time) , как да се форматира това да изкарва по-малко, само дата и час? Гледам в article модела следната функция:

date: {
    type: Sequelize.DATE,
    allowNull: false,
    required: true,
    defaultValue: Sequelize.NOW,
},

В  hbs файловете това май се взима с хендълбарс така:

{{this.date}}
Тагове:
0
Софтуерни технологии 18/07/2018 13:53:31
prohause avatar prohause 352 Точки

Пробвай така: {{formatDate date}}

0
chrisBG69 avatar chrisBG69 29 Точки
Error: \JS-Blog-design\views\article\details.hbs: Missing helper: "formatDate"
0
prohause avatar prohause 352 Точки

Оф то без хелпърите не ставаше. Ако напишете {{this.date.toLocaleString()}}

0
18/07/2018 14:31:12
chrisBG69 avatar chrisBG69 29 Точки

Абе не става и така, Parse Error, явно тука е хватката, но не знам как да се форматира:

date: {
    type: Sequelize.DATE,
    allowNull: false,
    required: true,
    defaultValue: Sequelize.NOW,
},
0
TihomirPavlov avatar TihomirPavlov 4 Точки

Здравейте,

от няколко часа се мъча да разбера къде бъркам! Следвам стъпките една след друга, описани в текстовия документ. Опитвам се да стартирам bin\www, изписва ми това съобщение:

"C:\Program Files\JetBrains\WebStorm 2018.1.5\bin\runnerw.exe" "C:\Program Files\nodejs\node.exe" C:\Users\Tihomir\Desktop\untitled\bin\www
Wed, 18 Jul 2018 16:49:48 GMT sequelize deprecated String based operators are now deprecated. Please use Symbol based operators for better security, read more at http://docs.sequelizejs.com/manual/tutorial/querying.html#operators at node_modules\sequelize\lib\sequelize.js:242:13
Initializing...
  untitled:server Listening on port 3000 +0ms
Unable to connect to the database!

Process finished with exit code 1
 и не се получава.

Някой имал ли е подобен проблем? Ще съм ви благодарен ако споделите. :)

 

0
TihomirPavlov avatar TihomirPavlov 4 Точки

Реших си проблема! :) Не съм стартирал xammp

 

0