Професионална програма
Loading...
dameb avatar dameb 0 Точки

Томкат7

Здравейте,

имам проблем сос стартоването на сервер томее, ме интересира дали и други имале проблем сос това,

и на кой начин да го реша, пробах сшто как и томкат 8, но не бива никако.

 

 

Тагове:
0
Java Web Development
RoYaL avatar RoYaL Trainer 6845 Точки

Нищо не разбрах.

0
dameb avatar dameb 0 Точки

I apologize because bulgarian is not my native language and I have difficulties writing in that language, 

Anyway my problem is that I can't start apache TomEE server and I was asking if someone else has 

the same problem and if they have a solution to the problem, wich is the following,

TomEE failed to start, 

I've tried everything on google.

0
RoYaL avatar RoYaL Trainer 6845 Точки

Can you try to explain your problem? How do you try to start the server? Using the IDE automatic deploy options or manually? What happens afterwards? Are there any errors on the screen? If yes, paste them here. If no, does the process of the server remain in the process list of your OS? Any other information might be helpful too. Maybe the operating system, you are trying to run the server should be mentioned too.

0
and1teachera avatar and1teachera 19 Точки

paste the output from your console

0
dameb avatar dameb 0 Точки

I'm using windows 7, and I'm starting it from the IDE automatic Deploy,

Feb 13, 2016 2:10:13 PM org.apache.catalina.startup.Catalina load
WARNING: Catalina.start using conf/server.xml: Error at (23, 76) : org.apache.catalina.startup.VersionLoggerListener
Feb 13, 2016 2:10:13 PM org.apache.catalina.startup.Catalina start
SEVERE: Cannot start server. Server instance is not configured.

I guess the problem got to do someting with the server.xml.

0
and1teachera avatar and1teachera 19 Точки
  1. I suspect your CATALINA_HOME is set wrong. Usually users writing path\bin; where it is only-path-to-tomcat without bin or any folder.

  2. Remove backslash \ at the end of the CATALINA_HOME

  3. You must check your tomcat log catalina.out to trace the route cause

  4. Also check your TOMCAT_HOME/conf/catalina.properties file.

1
and1teachera avatar and1teachera 19 Точки

also doble click on your server in eclipse that will open up server overview. Check the Server Locations section. The radio buton must be on the second option "Use Tomcat installation"

1
RoYaL avatar RoYaL Trainer 6845 Точки

Additionally check if your IDE does not have an option for using the IDE's proxy settings checked. It should be unchecked. Unfortunatelly I am unaware when it is located in Eclipse, but it should be where you configure servers for using.

1
deyan.zhekov avatar deyan.zhekov 159 Точки

Hi, 

have you set up the Eclipse to use the Tomcat location instead of the Workspace metadata?

Double click on the server -> Server Location -> Use Tomcat installation -> ctrl + s -> start the server

If you have something ready for publishing you need to remove it before trying to change the server location.

1
dameb avatar dameb 0 Точки

Thank you all for the help. 

What I did was I instaled the TomEE in different directory and changed the ports 

so they won't be the same with Tomcat 8.0 I'm guessing that even tho Tomcat 8.0 was turned off it still had some conflicts with the ports but it works now, and thank you again I appreciate your help.

0
TodorovH avatar TodorovH 216 Точки

Хм, постна се два пъти! Моля някой модератор да изтрие излишният пост! Благодаря!

0
13/02/2016 21:22:43