Софтуерно Инженерство
Loading...
+ Нов въпрос
BLShark avatar BLShark 2 Точки

Проблем при опит за зареждане на Qemu и TFTP

Колеги при опит да стартирам Qemu и TFTP (изпълнявам стпъките от лекция 4, слаид 42) ми изгърмява с тази грешка. Някой има ли идея за разрешаването на проблема ?

root@ubuntu:/opt/qemu/bin# sudo ./qemu-system-arm -M versatilepb -nographic -net nic -net tap,ifname=tap0 –kernel ~/uboot-2010.09/u-boot
/sbin/ifdown: interface eth0 not configured
Sun Feb  7 14:46:49 2016 ERROR: Cannot ioctl TUNSETIFF tap0: Device or resource busy (errno=16)
Sun Feb  7 14:46:49 2016 Exiting due to fatal error
/etc/qemu-ifup: 40: /etc/qemu-ifup: /sbin/service: not found
qemu-system-arm: -net tap,ifname=tap0: network script /etc/qemu-ifup failed with status 32512

Тагове:
0
Linux Курсове
denka avatar denka 52 Точки

1. Виж дали си сменил /usr/sbin/brctl със /sbin/brctl и в двата скрипта. (от слайд 39)

2. Пробвай ръчно двата скрипта дали работят както трябва преди да пуснеш горната команда:

sudo /etc/qemu-ifup tap0

sudo /etc/qemu-ifdown tap0

 

0
BLShark avatar BLShark 2 Точки

Тука има нещо интересно при опит за пускане на скрипт sudo /etc/qemu-ifup 

blshark@ubuntu:/etc$ sudo ./qemu-ifup 
/sbin/ifdown: interface eth0 not configured
Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: dev (2.3.2)
Use --help for more information.
0.0.0.0: ERROR while getting interface flags: No such device
0.0.0.0: ERROR while getting interface flags: No such device
Incorrect number of arguments for command
Usage: brctl addif <bridge> <device>    add interface to bridge

 

Иначе съм променил /usr/sbin/brctl със /sbin/brctl и в двата скрипта  и на виртуалката (VMware Workstation 12 ) съм сложил bridge connection, но без човка на "Replicate physical network connection state".

blshark@ubuntu:/etc$ sudo ./qemu-ifdown 
/sbin/ifdown: interface eth0 not configured
/sbin/ifdown: interface br0 not configured

Ignoring unknown interface eth0=eth0.
Options error: Unrecognized option or missing parameter(s) in [CMD-LINE]:1: dev (2.3.2)
Use --help for more information.

След това етх0 няма Ip addres и респективно нямам достъп и до интернет

 

 

0
08/02/2016 08:58:04
denka avatar denka 52 Точки

Tрябва да подадеш параметър: sudo /etc/qemu-ifup tap0

И в двата скрипта вътре има едно  $1, което ще се приеме стойността на подадения параметър (в случая трябва да е tap0). 

Провери също и предния bridge дали е ОК - Между твоята машина  и виртуалката.

Ако пак не стане дай един sudo ifconfig на твоята машина и на виртуалката, ама преди да пускаш командите и също дай кода на командите. 

0
sarfaa avatar sarfaa 17 Точки

Много е възможно името на този мрежов интерфейс да не е eth0.
На мен ми се случи да се казва eth12309347858.

Виж какво ти вади ifconfig като име.

1